OpenVPN

Discussões relacionadas à rede e serviços web, como Apache, bind, sendmail, etc.

OpenVPN

Mensagempor Adiel » 04/Jun/2013 17:01

Pessoal, boa tarde.
Instalei o FreeBSD 9.1-RElease, atualizei o sistema e recompilei o kernel a partir do source 9.0 Stable.
A parte relevante do arquivo de configuração de kernel é a de rede, deixei:
############################################
eth
tun
bpf
random
pf
###################################################
Instalei e configurei o OpenVPN, com a seguinte configuração:
################################################
local 192.168.254.122
port 1194
proto udp
dev tun
ca /usr/local/etc/openvpn/easy-rsa/keys/ca.crt
cert /usr/local/etc/openvpn/easy-rsa/keys/openvpn.crt
key /usr/local/etc/openvpn/easy-rsa/keys/openvpn.key
dh /usr/local/etc/openvpn/easy-rsa/keys/dh384.pem
server 172.20.0.0 255.255.255.240
push "route 192.168.254.0 255.255.255.0"
push "dhcp-options DNS 192.168.254.100"
keepalive 10 120
comp-lzo
max-clients 10
user nobody
group nobody
persist-key
persist-tun
status /var/log/openvpn.log
log /var/log/openvpn.log
log-append /var/log/openvpn.log
verb 3
mute 20
######################################################################
Estou utilizando um cliente Windows XP para me conectar, com a seguinte configuração:
##################################################################
client
dev tun
proto udp
remote 10.0.0.4 1194
persist-key
persist-tun
comp-lzo
ca ca.crt
cert client1.crt
key client1.key
verb 3
mute-replay-warnings
mute 20
#######################################################################
Configuração do Pf.conf:
##################################################################
set skip on lo
rdr on tun0 to any -> em0
pass in quick keep state
pass out quick keep state
######################################################################
Os clientes devem receber ips no range 172.20.0.0/28 e devem poder acessar a nossa rede interna 192.168.254.0/24.
Tudo que chega em 10.0.0.4 é encaminhado ao ip 192.168.254.122 do OpenVPN.
A VPN fecha corretamente e consigo enviar pings da máquina remota cliente para a rede interna, mas fica intermitente.
Acessos como RDP e CIFS não funcionam, os logs não retornam nenhuma anomalia.
Tcpdump também não retorna nada de errado.
Alguém tem alguma dica do que estou deixando passar?
Obrigado.
Adiel
Membro
 
Mensagens: 1
Registrado em: 11/Mar/2013 12:49

Voltar para Web & Serviços de Rede

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante

cron